Reply To: Help configuring with gallery plugin (majuscule)

Your Account / Forums / Easy FancyBox Pro / Help configuring with gallery plugin (majuscule) / Reply To: Help configuring with gallery plugin (majuscule)

January 10, 2014 at 1:36 am #3432

Hi Darrin, there is a lot going on on your site and there are vey many scripts loaded. You might say it’s a bit heavy which makes debugging difficult… If you have any plugins activated that you do not really use, You might want to start with disabling those.

Here are my observations so far:

1. First things I see is a “Uncaught TypeError: Cannot set property ‘A’ of undefined” script error occurring. I do not know what causes it but it seems related to a script loaded by the MapPress plugin or another plugin called WP GX Maps (or both) or caused by a conflict with CalPress Pro which seems to be loading the Google Maps API library too!! In any case it prevents all script action like the one from FancyBox that comes after that.

2. Then I notice that beside FancyBox and the prettyPhoto script from the theme, there is a third lightbox script loaded by a plugin called Calpress Pro. No idea yet if this is going to cause conflicts at some point.

3. And last but not least, it looks like the PWA+PHP plugin replaces the WordPress jQuery v1.10 library with it’s own version 1.7 (not even in noConflict mode) which is incompatible with Easy FancyBox 1.5+. Also, you seem to be using another version than the one on http://wordpress.org/plugins/pwaplusphp/. May I ask why? As far as I can tell, the one from WordPress Plugins repository uses the standard WP included jQuery library so if you can use that one, you might be better off…

Anyway, to get closer to solving this you will need some time and do a lot of testing. I’d suggest you start with these steps:
(a) Disable the Easy FancyBox Pro extension (for now) and uninstall Easy FancyBox free version.
(b) Go to http://wordpress.org/plugins/easy-fancybox/developers/ and look for 1.3.4.9 under Other Versions. Download the zip file and install that on your site via the WordPress Plugins > Add new > Upload dialog. Activate it and check the plugin settings.
(c) Disable the MapPress plugin and/or WP GX Maps and/or CalPress and test your site to see if the FancyBox starts working…

Hope that helps you further 🙂