Can't open popup with Revolution slider

Your Account / Forums / Easy FancyBox Pro / Can't open popup with Revolution slider

  • Author
    Posts
    • August 20, 2018 at 3:08 am #12512

      I tried to set the popup when you click text button in revolution slider, but it won’t open just keep loading. The code that I set as below.

      /* change revapi1 to whatever api number is being used for your slider */
      var api = revapi28;

      /* load a specific div from the page via Ajax */
      var ajaxContentContainer = ‘.terms_cond’;

      /* no need to edit below unless you want to change the default FancyBox settings */
      api.on(‘revolution.slide.onloaded’, function() {

      jQuery(this).find(‘.fancybox’).each(function() {

      var $this = jQuery(this);
      if(!$this.is(‘a’)) $this = $this.removeClass(‘fancybox’).find(‘a’);

      $this.addClass(‘fancybox fancybox.ajax’).attr(‘rel’, ‘gallery’).fancybox({

      /* begin FancyBox options */
      width: ‘auto’,
      height: ‘auto’,
      autoSize: true,
      aspectRatio: true,
      fitToView: true,
      autoCenter: true,
      scrolling: ‘auto’,
      onClosed: function() {api.revresume()},
      ajax: {
      dataFilter: function(data) {
      return jQuery(data).find(ajaxContentContainer)[0];
      }
      }

      }).on(‘click’, function() {api.revpause()});

      });

      });

      the page is :http://wp2.upauto.com/order32truck/

    • August 20, 2018 at 3:08 am #12514

      Hi, can you explain a bit more? I don’t see any Next buttons on that page. Nor is there a container with class terms_cond in the page source…

      I see the problem with the Terms and Conditions link though.

      Is your wish to open that link in a light box ?

      You could try the Terms in a PDF file:
      1. First, remove the extra code in revslider
      2. Put the terms and conditions in a PDF file and change the Terms and Conditions link to point to the PDF file
      3. Enable PDF autodetection on Settings > Media

       

  • You must be logged in to reply to this topic.