Disable Mouseover

Your Account / Forums / Easy FancyBox Pro / Disable Mouseover

Tagged: 

  • Author
    Posts
    • November 10, 2017 at 11:44 am #11287

      Hello,

      I don’t want to have any mouseover action on my pictures. Neither on the “normal” nor on the gallery. How can I disable it?

      Thank you,
      Frauke

    • November 10, 2017 at 11:44 am #11288

      Hi Frauke, welcome on these forums.

      What mouseover action are you seeing now? Easy FancyBox does not add any specific mouseover actions. Can you share a link to an example page?

    • November 10, 2017 at 11:44 am #11291

      Thanks for the prompt reply.

      On my website I have two kinds of mouseover actions:

      1) Here you can see the mouseover with the title on a linked picture and

      2) here you can find the mouseover with the file name of the picture in the gallery.

    • November 10, 2017 at 11:44 am #11298

      Ah! OK, I see what you mean. It is the browser doing that. It takes the image tag’s “title” attribute and transforms it into what is usually called a “tool tip”.

      FancyBox does not create not use this title attribute.

      To get rid of the browser tool tip, you’ll need to get rid of the image tag title attribute and in both examples these attributes are created by another plugin:

      1. On the gallery page I would think it’s the NextGen Gallery plugin that takes the image file name (without .JPG) by default. You might look in either the general plugin settings to disable this behavior or you’ll have to edit each gallery item to remove or alter this attribute. Note that it might even be called differently in the settings.

      2. On the other page, it looks to me like those are image elements created by the WPBakery page builder plugin. It creates both a “title” and “alt” attribute for each image tag. You could take a look at each of these elements to see if there are fields that correspond with each tooltip text. If there’s only one, then clear it and both the title and alt should disappear. Removing the alt attribute is not optimal (for SEO and accessibility reasons) but removing the title attribute will get rid of the tooltip. if there are two fields, then clear one of them, save and check the front-end to see if that’s the one. If the tooltip does not disappear, fill the field again and clear the other 🙂

      Sorry I cannot tell you exactly how to proceed. I’m not familiar with either of these plugins. You might get better info on their respective support forums.

      Let me know if you need more help!

    • November 10, 2017 at 11:44 am #11300

      The crucial hint was the fact that the problem hasn’t anything to do with the FancyBox 😉

      1) It was the NextCellent Gallery plugin and I could change the title.
      2) It was the WPBakery page builder plugin and I just removed the title.

      Now, it appears exactly as I want!

      Thanks a lot for your help !!!
      Frauke

    • November 10, 2017 at 11:44 am #11301

      Glad you were able to figure it out 🙂

  • You must be logged in to reply to this topic.