EasyFancyBox in contempt of "nolightbox"

Your Account / Forums / Easy FancyBox Pro / EasyFancyBox in contempt of "nolightbox"

  • Author
    Posts
    • August 7, 2018 at 4:48 pm #12462

      Hello,

      you helped me out quite a while ago with a code snippet, which shall prevent EasyFancyBox to open on product images of my shop, which also opened by ThickBox.

      The code was

      jQuery(document).on(‘ready post-load’, function(){ jQuery(‘a.wpsg_imagelink’).addClass(‘nolightbox’); });

      and is placed in a hidden widget and still seems to work, as the pictures does have the followig css-class: class=”wpsg_imagelink thickbox fancybox image nolightbox” – for an example see here.

      This worked for some time, but somehow it now stopped working (since an update of EFB) and I can’t figure out why – is you Pro version still supporting this class correctly?

      Many thank for your help in advance.

      Best regards,
      Joe

    • August 7, 2018 at 4:48 pm #12471

      Hi Joe, please try this code instead:

      
      jQuery(function(){
        jQuery(‘a.wpsg_imagelink’).addClass(‘nolightbox’);
      });
      
    • August 7, 2018 at 4:48 pm #12489

      Hi,

      thank you for you answer, sadly this code seems nothing to change in the code, when I inspect the site with the website developer tool of Safari.

    • August 7, 2018 at 4:48 pm #12498

      Hi Joe, I don’t see the code in your site source but I don’t see the double light box either. You seem to have resolved it differently?

    • August 7, 2018 at 4:48 pm #12516

      Hi, yes, in my active shop-system I patched the source-code directly, but this is always pain ITA, as I have to check this on every update of the system.

      Your code was tested on my test-shop (test.mywlan.de), but this is closed for the public.

    • August 7, 2018 at 4:48 pm #12527

      Hi Jörg, it may be caused by the fact that the Easy Fancybox scripts are loaded at a slightly different point in the latest version. You could try playing with the new option “script priority” in the compatibility options but it’s impossible say what would do the trick without seeing the issue…

      It would really help if this can be debugged live. Is there any possibility to have access to the test shop from the outside? If behind a login, you can send the info for the contact form with mention of this thread.

      What I do wonder is why the link shows both “fancybox image” and “nolightbox” in the class attribute at the same time… I’ll try to reproduce this locally.

  • You must be logged in to reply to this topic.