Fancybox with Glam Slider

Your Account / Forums / Easy FancyBox Pro / Fancybox with Glam Slider

  • Author
    • December 23, 2014 at 11:56 am #4218

      Is there a way of using Fancybox with the Glam Slider?

      When I turn on ‘lightbox’ in the Glam Slider settings, I get both Fancybox and Glam Slider lightboxes. Obviously I only want the one (fancybox).

      When I switch off ‘lightbox’ in the Glam Slider settings, then I don’t get any lightbox…. and I do have in my Fancybox settings switched on to ‘all image links’

      Is there a code or something I could add to specific images to get around this problem? This is fine for me to do if I could have an example of where to add it on an image

      I’d really like Fancybox to take the lightbox, and I need to with the ‘lightbox’ setting in Glam Slider switched off it seems

      Any help will be appreciated

    • December 23, 2014 at 11:56 am #4219

      Hi Gerard,

      Can you share a link to your web page with glam slider? I’ll probably be able to tell you what you would need to do to make FancyBox work on the slider images as well as all others…

    • December 23, 2014 at 11:56 am #4242

      Ive set up a test page where you see it on the link below (I am currently designing the site). As you will see when you click on the centre image it opens up in FancyBox lightbox which is great (black). However when you close it you will see the Glamslider lightbox underneath (white)

      On the page there are 2 tabs of settings which if you click on the images you will see what they are. Maybe there is a code I can put in here somewhere if nothing else works?

      I can switch the lighthbox setting off in Glam Slider so no light boxes open if this helps, at the moment I have left it on



    • December 23, 2014 at 11:56 am #4245

      Yes, please switch off the lightbox option in the Glamslider settings. Currently the FancyBox lightbox works fine so I need to see what changes when the lightbox option is off.

    • December 23, 2014 at 11:56 am #4246

      I have switched off the lightbox option in the Glamslider settings


    • December 23, 2014 at 11:56 am #4249

      OK, now I see what is happening: the link has changed from the full image version to an attachment page… Is there an option in Glamslider to keep the links pointing to the raw (full size) image as they do when the lightbox option is on?

      If not, then you can do three things:
      1. Ask the Glamslider developer to include this option (easiest, if the dev is willing to do it of course)
      2. Hack the Glamslider plugin yourself to remove the other lightbox (hard to do)
      3. Try to ‘neutralise’ the other lightbox with some custom javascript or PHP code (fastest)

      This last approach will need some searching. Can you please switch on the lightbox option again? I’ll try to find a way ๐Ÿ™‚

    • December 23, 2014 at 11:56 am #4252

      Thank you for your reply. I have switched the lightbox option back on in Glamslider

      I have also added 3 more screenshots to the test page which are snapshots of the settings options page in Glamslider (the rest are just border colour options, image/slider size etc)

      I guess option 2 or 3 to try and resolve this issue. I am happy to try some coding, I know it basically and can copy off the necessary scripts via FTP so can keep an untouched version incase it goes wrong, that I can just copy back over

      I would need a guide as to where and what code to add etc though


    • December 23, 2014 at 11:56 am #4283

      Hi Gerard,

      Looking at these Glam Slider options screenshots, you could try the following:
      1. Enable the lightbox option and then
      2. Use the field Slide Link Attributes (above it) to make the image links either have a class named “nofancybox” (which will disable fancybox for these slide images and let prettyPhoto take over) or to not have a rel=”prettPhoto” attribute.

      Not sure if this Slide Link Attributes field can be used for this but it’s worth a try ๐Ÿ™‚

    • December 23, 2014 at 11:56 am #4299

      I tried this but it didn’t work. I’ll leave this issue for the moment and will relook at it later when I have time. I’m leaving the lightbox switched off for the moment which is fine, though would be nice to be able to use Fancybox with it. Thanks for your help

    • December 23, 2014 at 11:56 am #4300

      If you can enable the Glamslider lightbox option one more time, I can attempt to devise a script snippet to place in a text widget or in the themes footer.php (before the wp_footer() call) that makes FancyBox ignore the slider links. It might not be the ideal solution (using two lightbox scripts instead of one) but at least you will be able to show both normal and slider image links in a lightbox…

    • December 23, 2014 at 11:56 am #4301

      I’ve switched it back on, but on the front end it isn’t working (it is on the settings page review) and I have no idea why. This seems to have started since I tried putting the a class code which I deleted now, but maybe something is hanging around somewhere. Is there a code I can put in that will open up Fancybox? If so, could you give me the exact code please and I’ll try it

      Also, I am creating a gallery page for my site and am getting the same 2 lighthbox issue on all the gallery plugins I have been looking at. Is there a gallery plugin you recommend that works well with fancybox? i.e. one fancy box lightbox

      Fancybox is working great on single images and PDF’s etc on my site and its just an image gallery issue. I don’t like the WP gallery plugin and want to use another one that has better features

    • December 23, 2014 at 11:56 am #4303

      Iโ€™ve switched it back on, but on the front end it isnโ€™t working (it is on the settings page review) and I have no idea why.

      That’s strange… Are you using page caching (like W3TC) maybe? Is there an option to reset Glamslider settings? If not, maybe you can get support from the Glamslider developers…

      This code might (untested) be able to suppress FancyBox for Glamslides:

      <script type="text/javascript">
      jQuery(document).on('ready', function(){
        jQuery('.glam_slide a').addClass('nofancybox');

      Paste it in a text widget in the sidebar.

      About gallery plugins: I have designed Easy FancyBox to work with the WordPress internal galleries primarily. You can add Jetpack’s Tiled Galleries module to that without problems. But other Gallery plugins usually bring along their own lightbox and are all implemented very differently.

      I have had reports that you can use NextGEN Gallery with Easy FancyBox but I’m told it’s very difficult to find the right settings as it is a very complicated plugin. You can find some suggestions in the FAQ’s but these are old and the plugin has become even more complex since then. I don’t like it for that very reason. It’s bigger than WordPress itself and way too much overhead for my taste. And if you ever try NextGEN Pro, apparently you’ll run into the same problem of double lightboxes again.

      There is a solution similar to the one suggested for the Glamslider but you have to consider that each time you are adding a different lightbox, page load times will increase. Sometimes a lot, which is bad for your visitor stats.

    • December 23, 2014 at 11:56 am #4306

      I pasted into a text widget in my sidebar but all that happened is seeing the text code on the sidebar. Maybe this is better pasted into the footer script. Though I think I probably need to reinstall Glamslider as the lightbox function is not working and suggests something has gone wrong somewhere in the plugin script, so maybe this is why. Though at the moment this would mean having to redo all the slider galleries, so will look at it when I have more time to do so. Besides if I use a lightbox for Glamslider, I only want to use Fancybox

      Thanks for all the info re image galleries. I have quite a few gallery events I need to add to my site and will look at the image galleries you suggested, and use one of these. The code you suggested adding to the footer seems to work from the user who tried it, so I’ll probably go this route if I can

  • You must be logged in to reply to this topic.