Mobile Phones – plugin not supported?

Your Account / Forums / Easy FancyBox Pro / Mobile Phones – plugin not supported?

  • Author
    • November 27, 2014 at 6:59 am #4080

      Hi, sorry if this has been covered already but I didn’t see it so I needed to ask. I was using your free version and I liked it very much. I upgraded to your Easy FancyBox Pro because the free version displayed, “Plugin Not Supported” on my Samsung Galaxy 2 Note. I noticed on your url that your before and after images loaded just fine on my mobile device so I assumed that if I bought your pro version that my images would load after I installed your pro version on my site. However, I just tested my site on my mobile phone and it still says, “Plugin not supported”. Is there a setting I’m not seeing somewhere that would fix this? Thank you! My site is at Thank you.

    • November 27, 2014 at 6:59 am #4082


      The massage “Plugin Not Supported” can not be coming from Easy FancyBox. It has no such feature… So there must be something else going on on your site.

      Can you please tell me more about how to reproduce the issue? Which link do I follow to see the message?

    • November 27, 2014 at 6:59 am #4426

      My only issue is that on mobile phone web browsers PDF files won’t load in lightbox and say, “Plugin not supported”. Everything else works perfectly. Example page If you click on the product image I have it set to open a PDF File. It works fine on desktop or laptop browser but mobile phone says, “Plugin not supported”. Is there a setting somewhere I can change to make mobile phones display PDF Files in lightbox?

    • November 27, 2014 at 6:59 am #4438

      OK I see. The message “Plugin not supported” is coming from the mobile browser. It is talking about a browser plugin (not WordPress plugin) that is needed to display PDF files. There is nothing I can do about that from within the Easy FancyBox WP plugin…

      However, not being able to make the mobile browser display the PDF you might still be able to change the behavior. Try this:

      1. Go to Setttings > Media and disbale the PDF option and enable the iFrame option.
      2. Remove the “.pdf” from the Auto-detect field in the Images section (it does not belong there as it will make FancyBox think PDF files are images!)
      3. Modify your PDF links in the HTML editor tab so that they will have a class “fancybox-iframe”
      4. Test the links on the mobile device to see if the browser now downloads the file instead of trying to render it…

      P.S. Better to disable all media types on Settings > Media that you are not actually using on your site. Leaving all options enabled makes your site slower than it needs to be.

    • November 27, 2014 at 6:59 am #4446

      I have some issue with magnific and giving js error referring to fancybox?
      The below is the error :

      Uncaught TypeError: undefined is not a function magnific-custom.js:54
      The above error refers to the following code :
      $(this).fadeTo(250, 1).siblings().fadeTo(250, 0.5);
      return false;
      It is referring to ‘fancybox’.
      Can you please throw some light on this error.
      Thanking you in advance.

      Page link :

    • November 27, 2014 at 6:59 am #4536

      Hi, it seems the error has gone. How did you solve it?

  • You must be logged in to reply to this topic.