Problems Detecting Videos

Your Account / Forums / Easy FancyBox Pro / Problems Detecting Videos

  • Author
    Posts
    • August 22, 2017 at 1:49 pm #8530

      I have Easy FancyBox Pro installed on our site but I am having problems getting it to detect videos. I have the autodetect options checked and I’ve added the class=”fancybox-vimeo” attribute to all of the vimeo videos on our homepage but they do not seem to appear in the lightbox sequence or slideshows. I am having the same problems with YouTube videos embedded elsewhere on our site.

    • August 22, 2017 at 1:49 pm #8531

      You can see an example at https://www.n1fd.org/

    • August 22, 2017 at 1:49 pm #8535

      Hi Fred,

      Sorry this was not clear before: FancyBox needs a link to the vimeo page to work with. Simply pasting the vimeo address alone (not making a link) will cause WordPress to embed the video straight on the page. Visitors may view the video without the light box effect.

      To get the light box to work here, first create a screen print of the video or any other image that you want as thumbnail, then insert that image on the page while setting the option “Link to” to “Custom URL” and paste the vimeo address there. Alternatively, you can decide not to use a thumbnail image and just create a basic text link, pointing to a vimeo page.

      Either way, this will create a link that pops up a light box with the video on the linked vimeo page.

  • You must be logged in to reply to this topic.