Woocommerce interaction ?

Your Account / Forums / Easy FancyBox Pro / Woocommerce interaction ?

  • Author
    Posts
    • September 6, 2016 at 6:30 pm #6984

      Hi,

      I think I have the problem reported in that topic:
      https://premium.status301.net/support/topic/problem-galery/

      But unfortunatly, it doesn’t seems possible anymore to disabled woocommerce Lightbox “plugin”.

      Do you have an other Idea to make it works

      Page:
      http://www.thegreenid.com/projets/nobrownafter6-85APlS5A6iZK5Z5z2jZ/commande/

      Add a product to the cart and when you process the order, the content I want in a fancybox are the terms of sales at the bottom of the page. In french, you will see: “Conditions générales de vente”

      Thanks,

      Jean-Pascal

    • September 6, 2016 at 6:30 pm #6988

      Hi Jean-Pascal, welcome on these forums 🙂

      Looking at your site, it does not seem to be a conflict with the Woocommerce light box. I suspect it is related to the fact that the checkout page content (including that terms page link) is loaded dynamically via an ajax request. This means that FancyBox is not aware of the existence of this link and does not bind itself to it.

      I suspect it is the Enfold theme that does the dynamic loading of pages. Or maybe it’s Woocommerce? In any case, if is there an option to switch that effect off, either for the complete site or for the checkout pages (panier + commande) specifically, then try that to see if FancyBox starts working…

      .Rolf

    • September 6, 2016 at 6:30 pm #6992

      Thank you for the welcome message . Apart from this problem, I find your plugin very useful (which is why I hope to find a solution !)

      What is very strange, is that if I had id=”fancybox-auto” it works fine. The content is found and the fancybox opens very well. You can check it now, still on the same page.

      If it was a problem of ajax loading, it should fail as well with fancybox autoload, no ?

      Thx,

      JP

    • September 6, 2016 at 6:30 pm #6995

      If it was a problem of ajax loading, it should fail as well with fancybox autoload, no ?

      You are right, it looks like FancyBox binds to the link just fine. This means that another script is interfering right after clicking the link, but before FancyBox can jump in to open the light box frame.

      Can you go into the Enfold options and find and disable the option “Page Transitions” ?

    • September 6, 2016 at 6:30 pm #6996

      I think the option in French is called “Transitions de page” right under “Préchargement de page” on the “Options du thème” admin page.

    • September 6, 2016 at 6:30 pm #6997

      I both tried to disable “Lightbox Modal Window” and “Page Transitions”, but it’s not successful.

    • September 6, 2016 at 6:30 pm #6998

      Have you tried disabling the main option “Préchargement de page” ?

      It’s impossible for me to find out what exactly is going on, with so much going on at the same time (Woocommerce, Enfold) so the best way would be to eliminate all possible conflicts. If possible, could you switch to the default theme for a minute? Or recreate a similar CGV link on another page or in a footer widget?

      Or, if you want, I can take a look and do some tests if you create a temporary admin account on the site for ravanhagen at gmail dot com

    • September 6, 2016 at 6:30 pm #7009

      Thank you. I just created you an account. Hope you can find what interact with EasyfancyBox Pro. I have been using it with enfold in an other project and it was working well.

  • You must be logged in to reply to this topic.